logo-jonsch

Stacking Probleme bei Cisco Catalyst 9200/9300



Beitragsbaum




Vorwort

Ein Meilenstein der Cisco Catalyst Historie hat sein Ende gefunden. Das Modell 2960X ist bereits End of Life und hat auch schon einen Nachfolger in petto. Die Ablöse macht hier der C9200 und fällt auch gleich durch das neue grau-in-grau Design auf. Wer's mag, bitte. Grundlegend hat sich nichts geändert bis auf das OS, da in der 9000er Reihe nun komplett auf IOS-XE gesetzt wird. Man muss sich halt damit abfinden, dass IOS langsam dem Tode geweiht ist und einfach Platz machen muss. Das Modell 9200 gibt es einmal als modulare oder fixe Einheit und es gibt eine Art Lite-Version des Switches, welcher einfach weniger Leistung und keine Modularität mit sich bringt. Diese Variante schimpft sich dann C9200L.




Problem: Stacking

Soweit so gut. Für ein Projekt habe ich auch gleich zehn dieser Switche mit Stacking Modul und Kabeln bestellt. Damit ich die 9200er auch konfigurieren kann, wollte ich diese in einem Zweierstack betreiben. Also habe ich die zwei Switche ganz klassisch über kreuz gestackt und nacheinander gebootet. Finden tun sich die Switche dann automatisch und falls notwendig, spielt der Master noch die gleiche Software auf seinen Slave. So viel zur Theorie, allerdings möchten meine nicht so wirklich...

C9200 Stacking Fail


"Stack cable authentication failed..." ehm what? Dieser Fehler ist mir neu und konnte damit auch erstmal nichts anfangen. Vielleicht hat Cisco auch einfach die Art des Stackings geändert, anstatt über Kreuz jetzt gerade stacken? Ohne Erfolg. Ein zweiter Versuch nach Austausch der Stacking Kabeln bleibt auch erfolglos. Ich habe dann zwei neue Switche genommen, miteinander gestackt und konnte das Fehlerbild reproduzieren. Auch hier habe ich mehrere Stacking Kabel, verschiedene Stacking Arten und noch weitere Switche versucht. Kein Erfolg. So langsam wurde ich skeptisch. Könnte es an einem Bug des Images auf dem Switch liegen? Nein, auch dieses habe ich downgegradet und upgegradet. Keine Veränderung. Daher habe ich mich dann an den Tech Support von Cisco gewandt und dort wurde mir dann gesagt, dass die Stacking Kabel ausgetauscht werden müssen. Nachdem alle Formalien geklärt wurden, began der Austauschprozess seitens Cisco. Nun heißt es warten, was für ein Glück nur bis zu sechs Wochen... Die Kabel werden anscheinend noch handgemacht.


Ich dachte bis dato nicht daran, dass die Stacking Kabel einen Schlag haben könnten. Mal ganz im Ernst, wenn jetzt langsam schon eine grundlegende Funktion wie Stacking solche Probleme verursacht fange ich langsam bezüglich der Qualität der Cisco Produkte ernsthaft zu zweifeln. Was soll denn an den Kabeln falsch sein? Defekte Charge oder Fakeprodukte eines Zwischenhändlers? Indizien lassen sich eventuell erst nach Eintreffen der neuen Kabel finden...




Des Lösungs... Kabel

Nach sage und schreibe vier Wochen trudelt die Hardware ein. Man nehme die ersten zwei Switche, dazu zwei neue Stacking Kabel, stackt die Switche über Kreuz und siehe da, die Switche booten problemlos als Stack. Was soll ich dazu sagen? Probleme mit dem Stacking von Switchen hatte ich bis dato auch noch nicht von Cisco gekannt, man lernt halt nie aus. Zumindest werden die Probleme relativ abwechslungsreich für uns Admins gestaltet.


Auf den ersten Blick sehen die neuen Kabel mit den Alten identisch aus. Wenn man aber genauer hinsieht fällt einem bei der defekten Charge die schlechte Formatierung der Label auf. Außerdem scheint die Produktnummer (PID) unterschiedlich zu sein.

Stacking Cable Difference Stacking Cable Format Difference


Ich kenne eine schlechte Formatierung von Labels und OVP's meistens bei gefälschten Produkten, daher bin ich hier etwas skeptisch. Gefälschte Cisco Produkte sind jetzt auch keine neue Erkenntnis, da muss man nur kurz mal googlen und findet da bereits Treffer, beispielsweise Polizei nimmt Cisco-Fälscher hoch und viele mehr. Ich hatte bereits in der Vergangenheit die Bekanntschaft mit gefälschten Cisco Switchen gehabt. Ein Upgradeprozess des OS schafft da Klarheit... dann wenn nichts mehr funktioniert und der Tech Support einem mitteilt, dass die Seriennummer des Switches seitens Cisco nicht existiert. *g*


Mich würde es auch nicht wundern, wenn die Stacking Kabel hier einfach nur vertauscht wurden und für ein anderes Modell der Cisco Reihe gedacht waren. Im WWW finde ich allerdings überall die "A0"-Variante für die 9200/9300 Serie angeboten. Trotzdem ähneln die Stacking Kabeln sehr denen für die 3750X und 3850X Reihe.


Auf Nachfrage bei dem Tech Support habe ich keine Informationen zu dem eigentlichen Fehler erhalten. Keine Antwort ist auch eine Antwort. Täglich grüßt das Murmeltier.




over & out,
jonsch